Schoology - 常见问题(FAQ)
如果您还没有在 Schoology 中使用过 Flat for Education,欢迎先查看我们的入门介绍。
排查 Schoology 集成错误
本资源旨在为在 Schoology 中搭配使用 Flat for Education 时最常见的问题提供解决方案。如果您在此未找到所需答案,请联系我们的团队!
- [“未找到 LTI consumer key”】【#_1-未找到-lti-consumer-key-请检查您是否正确复制了我们的-consumer-key-或您正在使用的-consumer-key-是否与您账户中显示的一致)
- [“OIDC state 无效”】【#_2-oidc-state-无效-我们所有的-lti-13-请求都需要有效的-oidc-登录)
1. “未找到 LTI consumer key。请检查您是否正确复制了我们的 Consumer key,或您正在使用的 Consumer key 是否与您账户中显示的一致”

问题原因
您在 Schoology 中填写的 Consumer key 或 Consumer Secret 不正确。
解决方法
请核对您在 Schoology 中输入的 Consumer key 与 Consumer Secret 是否正确。
如果之前一直正常、近期才开始出现该错误,通常是因为最初配置 LTI 集成的教师已离开学校,从而导致配置被移除。请联系您当前的管理员重新发起一次 LTI 配置,并将新的凭据填写到 Schoology 中。
2. “OIDC state 无效。我们所有的 LTI 1.3 请求都需要有效的 OIDC 登录”

问题原因
当 Schoology 未能发送正确完成身份验证的 LTI 请求时,会出现此错误。通常是由于 Schoology 环境中的配置不当导致安全握手失败而引起。
解决方法
请尝试以下步骤来解决问题:
- 确认课程访问范围: 请确保在安装应用时选择了“All Courses(所有课程)”。您可以在 Schoology App Center 中,进入 Flat for Education 的“Configure(配置)”设置进行检查。

- 重新安装应用: 有时需要重新安装,以便在两个平台之间正确重置 LTI 1.3 的安全令牌。
如果您已尝试以上两项仍然出现同样的错误,请联系 Schoology 技术支持。由于权限与日志可见范围有限,Flat for Education 对该错误的排查能力也有限。
如有任何不清楚之处,欢迎随时联系我们——我们的支持团队随时为您提供帮助!
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